<!doctype html>
<html lang="en" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#" class="no-js">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <!--PD DFP Tags-->
    <script type='text/javascript'>
      var googletag = window.googletag || {};
      googletag.cmd = googletag.cmd || [];
      function is_mobile() {
        var WindowWidth = Math.min( typeof document.documentElement.clientWidth !== 'undefined' ? document.documentElement.clientWidth : 9999, typeof window.innerWidth !== 'undefined' ? window.innerWidth : 9999, typeof window.screen !== 'undefined' && typeof window.screen.width !== 'undefined' ? window.screen.width : 9999);
        if (WindowWidth < 728) {
          return true;
        } else {
          return false;
        }
      }
      var isMobileResult = is_mobile();
    </script>

          <script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net" src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/phonedog-article/phonedog-article.min.js"></script>
      <script type='text/javascript'>
        if (!isMobileResult) {
          googletag.cmd.push(function() {
            googletag.defineSlot('/41014381/PhoneDog/PD_Article_300x250_A', [[300, 250], [300, 600]],'dfp-gpt-ad-300x250-a').addService(googletag.pubads());
            googletag.defineSlot('/41014381/PhoneDog/PD_Article_300x250_B', [[300, 250], [300, 600]],'dfp-gpt-ad-300x250-b').addService(googletag.pubads());
            googletag.defineSlot('/41014381/PhoneDog/PD_Article_300x250_C', [[300, 250], [300, 600]],'dfp-gpt-ad-300x250-c').addService(googletag.pubads());
            googletag.defineSlot('/41014381/PhoneDog/PD_Article_728x90_A', [728, 90], 'dfp-gpt-ad-728x90-a').addService(googletag.pubads());
            googletag.defineSlot('/41014381/PhoneDog/PD_Article_728x90_B', [728, 90], 'dfp-gpt-ad-728x90-b').addService(googletag.pubads());
            googletag.defineSlot('/41014381/PhoneDog/PD_Article_728x90_C', [728, 90], 'dfp-gpt-ad-728x90-c').addService(googletag.pubads());
          });
        }
      </script>
        <script type='text/javascript'>
      googletag.cmd.push(function() {
        if (isMobileResult) {
          googletag.defineSlot('/41014381/PhoneDog/PD_Mobile_320x50', [320, 50], 'dfp-gpt-ad-320x50-a').addService(googletag.pubads());
        }
        googletag.pubads().enableAsyncRendering();
        bizxPrebid.Ads.pushToGoogle();
        googletag.enableServices();
      });
    </script>
    <!--End PD DFP Tags-->


    <!--[if IE]><![endif]-->
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<![endif]--><meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="amphtml" href="https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro?amp" />
<link rel="shortcut icon" href="https://www.phonedog.com/sites/phonedog.com/themes/phonedog/favicon.ico" type="image/vnd.microsoft.icon" />
<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@graph": [
        {
            "@type": "NewsArticle",
            "headline": "Are you interested in Samsung\u0027s XCover Pro?",
            "name": "Are you interested in Samsung\u0027s XCover Pro?",
            "description": "There might not be as many of them today as there used to be, but rugged phones are still a thing. Samsung used to be one of the companies out there in the wild releasing new tough handsets on a regular basis, so it\u0027s not really a surprise to see the company coming back with a new idea in 2020.",
            "author": {
                "@type": "Person",
                "@id": "https://www.phonedog.com/authors/EvanPSelleck",
                "name": "Evan Selleck",
                "url": "https://www.phonedog.com/authors/EvanPSelleck"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.phonedog.com/",
                "name": "PhoneDog Media",
                "url": "https://www.phonedog.com/",
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://www.phonedog.com/sites/www.phonedog.com/themes/phonedog/images/logo-GN.png",
                    "width": "310",
                    "height": "60"
                }
            },
            "datePublished": "2020-01-13T10:14:44-0800",
            "dateModified": "2020-01-13T10:17:00-0800",
            "image": {
                "@type": "ImageObject",
                "representativeOfPage": "True",
                "url": "https://www.phonedog.com/sites/phonedog.com/files/blog/main_image/2020/01/galaxy-xcover-pro-official_0.jpg",
                "width": "1456",
                "height": "1200"
            },
            "mainEntityOfPage": "https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro",
            "about": [
                "Samsung",
                "Android",
                "XCover Pro"
            ]
        }
    ]
}</script>
<meta name="description" content="There might not be as many of them today as there used to be, but rugged phones are still a thing. Samsung used to be one of the companies out there in the wild releasing new tough handsets on a regular basis, so it&#039;s not really a surprise to see the company coming back with a new idea in 2020." />
<meta name="thumbnail" content="https://www.phonedog.com/sites/phonedog.com/files/blog/featured_image/2020/01/galaxy-xcover-pro-official.jpg" />
<meta name="rating" content="general" />
<meta name="referrer" content="unsafe-url" />
<link rel="image_src" href="https://www.phonedog.com/sites/phonedog.com/files/blog/main_image/2020/01/galaxy-xcover-pro-official_0.jpg" />
<meta name="rights" content="© 2001-2020 PhoneDog, LLC. Reproduction without explicit permission is prohibited. All Rights Reserved." />
<link rel="canonical" href="https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro" />
<link rel="shortlink" href="https://www.phonedog.com/node/106083" />
<meta property="og:site_name" content="PhoneDog" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Are you interested in Samsung&#039;s XCover Pro?" />
<meta property="og:url" content="https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro" />
<meta property="og:description" content="There might not be as many of them today as there used to be, but rugged phones are still a thing. Samsung used to be one of the companies out there in the wild releasing new tough handsets on a regular basis, so it&#039;s not really a surprise to see the company coming back with a new idea in 2020." />
<meta property="og:updated_time" content="2020-01-13T10:17:00-08:00" />
<meta property="og:image" content="https://www.phonedog.com/sites/phonedog.com/files/blog/main_image/2020/01/galaxy-xcover-pro-official_0.jpg" />
<meta property="og:image:url" content="https://www.phonedog.com/sites/phonedog.com/files/blog/main_image/2020/01/galaxy-xcover-pro-official_0.jpg" />
<meta property="og:image:width" content="1456" />
<meta property="og:image:height" content="1200" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@phonedog" />
<meta name="twitter:url" content="https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro" />
<meta name="twitter:description" content="There might not be as many of them today as there used to be, but rugged phones are still a thing. Samsung used to be one of the companies out there in the wild releasing new tough handsets on a regular basis, so it&#039;s not really a surprise to see the company coming back with a new idea in 2020." />
<meta name="twitter:title" content="Are you interested in Samsung&#039;s XCover Pro?" />
<meta name="twitter:image" content="https://www.phonedog.com/sites/phonedog.com/files/blog/main_image/2020/01/galaxy-xcover-pro-official_0.jpg" />
<meta name="twitter:image:width" content="1456" />
<meta name="twitter:image:height" content="1200" />
<meta name="twitter:image:alt" content="Samsung XCover Pro" />
<meta property="article:author" content="https://www.facebook.com/phonedog" />
<meta property="article:published_time" content="2020-01-13T10:14:44-08:00" />
<meta property="article:modified_time" content="2020-01-13T10:17:00-08:00" />
    <meta charset="UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge; chrome=1" />
        <meta content="width=device-width, initial-scale=1.0" name="viewport" class="viewport" />
    <meta property="fb:pages" content="27849291760" />
    <title>Are you interested in Samsung's XCover Pro? | PhoneDog</title>
            <link rel="icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/195x195image.png" /><!-- Opera Speed Dial icon -->
    <link rel="apple-touch-icon" type="image/png" sizes="152x152" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-152x152.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-128x128.png" /><!-- Chrome Web Store icon -->
    <link rel="apple-touch-icon" type="image/png" sizes="120x120" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-120x120.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-114x114.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-96x96.png" />
    <link rel="apple-touch-icon" type="image/png" sizes="76x76" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-76x76.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-72x72.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-57x57.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-32x32.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-24x24.png" />
    <link rel="apple-touch-icon-precomposed" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon-precomposed.png" />
    <link rel="apple-touch-icon" type="image/png" href="/sites/phonedog.com/themes/phonedog/images/apple-touch-icon/apple-touch-icon.png" />
    <link rel="shortcut icon" type="image/x-icon" href="/sites/phonedog.com/themes/phonedog/favicon.ico" />
    <link rel="dns-prefetch" href="//analytics.phonedog.com/">
    <link rel="dns-prefetch" href="//a.phonedog.com/">
    <link rel="dns-prefetch" href="//www.googletagservices.com/">
    <link rel="dns-prefetch" href="//load.instinctiveads.com/">
    <link rel="dns-prefetch" href="//fonts.googleapis.com/">
    <link rel="dns-prefetch" href="//fonts.gstatic.com/">
    <link rel="dns-prefetch" href="//pagead2.googlesyndication.com/">
    <link rel="dns-prefetch" href="//apis.google.com/">
    <link rel="dns-prefetch" href="//www.youtube.com/">
    <link rel="dns-prefetch" href="//www.facebook.com/">
    <link rel="dns-prefetch" href="//connect.facebook.net/">
    <link rel="dns-prefetch" href="//graph.facebook.net/">
    <link rel="dns-prefetch" href="//syndication.twitter.com/">
    <link rel="dns-prefetch" href="//cdn.api.twitter.com/">
    <link rel="dns-prefetch" href="//tag.crsspxl.com/">
    <link rel="dns-prefetch" href="//static.yieldmo.com/">
    <link rel="dns-prefetch" href="//googletagservices.com/">
    <link rel="prefetch" href="//apis.google.com/js/platform.js">
    <link rel="prefetch" href="/sites/phonedog.com/files/json/wireless_plans_listing.js">
    <link rel="prefetch" href="/sites/phonedog.com/files/json/wireless_phones_listing.js">
    <link type="text/css" rel="stylesheet" href="//www.phonedog.com/sites/phonedog.com/files/css/css_Vts0XjaQXkIwBk9HNAoJwrvmmE9lw6S9oxqJuhh0OB0.css" />
<link type="text/css" rel="stylesheet" href="//www.phonedog.com/sites/phonedog.com/files/css/css_wmuNFF40WffTMKH6nYrgL3s1gjFIlh73TuTNVGu5wgs.css" />
<link type="text/css" rel="stylesheet" href="//www.phonedog.com/sites/phonedog.com/files/css/css_i8wVIZk1RPW01jXicIPZykBBm82ULo_uwbuOJ3rhZ_U.css" />
<link type="text/css" rel="stylesheet" href="//www.phonedog.com/sites/phonedog.com/files/css/css_1mwsI6zW8GMmarDI4jZ6ciyAlgdQFB5Af_HuaS0OQSQ.css" />
<link type="text/css" rel="stylesheet" href="//www.phonedog.com/sites/phonedog.com/files/css/css_FJSQei0uR9xnXDQIDG9FLPV4p01xo5yjuQNGhDyB-p0.css" />

              
    <!--[if gte IE 9]><style>.gradient{filter:none;}</style><![endif]-->
          <script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_dszO-ahkZfkzl_IzeJIxuNSq35rlurEYvKj_Bqk_FAw.js"></script>
    
    
    <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({article:'auto'});
      !function (e, f, u) {
        e.async = 1;
        e.src = u;
        f.parentNode.insertBefore(e, f);
      }(document.createElement('script'),
      document.getElementsByTagName('script')[0],
      '//cdn.taboola.com/libtrc/windnseamobilepartners-phonedog/loader.js');
    </script>

      </head>
  <body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-106083 node-type-blog"   onunload="">
    
        <header> <div class="header-top"> <div class="row main-menu"> <div class="logo"> <a href="/" title="Home" rel="home"> <img src="/sites/phonedog.com/themes/phonedog/images/logo.png" id="dogfce" alt="" /> </a> </div> <span class="mobile-menu"> <img class="mobile-menu-toggle" src="/sites/phonedog.com/themes/phonedog/images/mobile-menu-toggle.png" alt="Menu" /> </span> <!-- /.mobile-menu --> <a class="mobile-phonedog-logo" href="/" title="Home" rel="home"> <img src="/sites/phonedog.com/themes/phonedog/images/mobile-phonedog-logo.png" alt="phonedog" /> </a> <!-- /.mobile-phonedog-logo --> <div class="top-navigation"> <ul id="main-menu" class="links inline clearfix"><li class="menu-3935 first"><a href="/cell-phone-research/compare-plans">Cell Phones &amp; Plans</a></li>
<li class="menu-3933"><a href="/business-phone-service">Business Phone</a></li>
<li class="menu-3934"><a href="/compare-home-phone-service">Home Phone</a></li>
<li class="menu-3936"><a href="/internet">Internet</a></li>
<li class="menu-3937"><a href="/compare-tv-providers">Television</a></li>
<li class="menu-9971 last"><a href="/cell-phone-smartphone-deals" title="Cell Phone &amp; Smartphone Deals" name="Cell Phone &amp; Smartphone Deals">Deals</a></li>
</ul> </div> </div> <!-- /.row, .main-menu --> <div class="dropdown-menu-container clearfix"> <div class="nav-dropdown nav-dropdown-1"> <div class="dropdown-pads clearfix"> <div class="dropdown-callout"> <h2>Find the Best Cell Phone <span> and Plan for You</span></h2> <img class="phone-tool-img-col" src="/sites/phonedog.com/themes/phonedog/images/phone-plan-dd.png" alt="Find the best Callphone and Plan for you" /> <p>PhoneDog's innovative comparison tool can help you save on cell phones and plans. Find the best phone and plan for you today with PhoneDog!</p> <div class="btn-container"> <a href="/cell-phone-research/compare-plans">Compare Phones and Plans</a> <a href="/products/find">Compare Cell Phones</a> </div> <!-- /.btn-container --> </div> <!-- /.dropdown-callout --> <div class="dropdown-col-container"> <div class="dd-col col-1"> <div class="dd-phones-with-plans dd-wrap"> <ul id="menu-phones-with-plans" class="menu-phones-with-plans"><li class="menu-4255 first"><a href="/cell-phone-research/compare-plans">Compare Cell Plans</a></li>
<li class="menu-10503"><a href="/carriers/credo-mobile/reviews">CREDO Mobile</a></li>
<li class="menu-10494"><a href="/carriers/tello/reviews">Tello</a></li>
<li class="menu-10495"><a href="/carrier/ting/reviews">Ting</a></li>
<li class="menu-4258"><a href="/carriers/t-mobile/reviews">T-Mobile</a></li>
<li class="menu-4257"><a href="/carriers/sprint/reviews">Sprint</a></li>
<li class="menu-10502"><a href="/carriers/pix-wireless/reviews">Pix Wireless</a></li>
<li class="menu-10497"><a href="/carriers/the-peoples-operator/reviews">The People&#039;s Operator</a></li>
<li class="menu-10496"><a href="/carriers/republic-wireless/reviews">Republic Wireless</a></li>
<li class="menu-10498"><a href="/carriers/boost-mobile/reviews">Boost Mobile</a></li>
<li class="menu-10501"><a href="/carriers/straight-talk/reviews">Straight Talk</a></li>
<li class="menu-4259"><a href="/carriers/at-t/reviews">AT&amp;T</a></li>
<li class="menu-10499"><a href="/carriers/virgin-mobile/reviews">Virgin Mobile</a></li>
<li class="menu-4256"><a href="/carriers/verizon-wireless/reviews">Verizon Wireless</a></li>
<li class="menu-10500 last"><a href="/carriers/net10/reviews">Net10</a></li>
</ul> </div> <!-- /.dd-phones-with-plans --> <div class="dd-no-contact-phones dd-wrap"> <ul id="menu-no-contract-phones" class="menu-no-contract-phones"><li class="menu-4261 first"><a href="/carriers/prepaid-plans"> No Contract Plans</a></li>
<li class="menu-7101 last"><a href="/carriers">See all carriers</a></li>
</ul> </div> <!-- /.dd-no-contract-phones --> </div> <!-- /.col-1 --> <div class="dd-col col-2"> <div class="dd-phones-categories dd-wrap"> <ul id="menu-phones-categories" class="menu-phones-categories"><li class="menu-4270 first"><a href="/products/find">Phone Categories</a></li>
<li class="menu-4271"><a href="/products/smartphones">Smartphone</a></li>
<li class="menu-4272"><a href="/products/basic-phones">Basic Phones</a></li>
<li class="menu-4273"><a href="/products/waterproof-rugged-phones">Waterproof/Rugged</a></li>
<li class="menu-4274"><a href="/products/phablets">Phablets</a></li>
<li class="menu-4275 last"><a href="/cell-phone-shopping/specials">Free Phones</a></li>
</ul> </div> <!-- /.dd-phones-categories --> <div class="dd-phone-manufacturers dd-wrap"> <ul id="menu-phone-manufacturers" class="menu-phone-manufacturers"><li class="menu-4277 first"><a href="/manufacturers">Phone Manufacturers</a></li>
<li class="menu-4278"><a href="/manufacturers/apple/products">Apple</a></li>
<li class="menu-4279"><a href="/manufacturers/htc/products">HTC</a></li>
<li class="menu-4280"><a href="/manufacturers/motorola/products">Motorola</a></li>
<li class="menu-4281"><a href="/manufacturers/lg/products">LG</a></li>
<li class="menu-4282"><a href="/manufacturers/samsung/products">Samsung</a></li>
<li class="menu-4283 last"><a href="/manufacturers">See All Manufacturers</a></li>
</ul> </div> <!-- /.dd-phone-manufacturers --> </div> <!-- /.col-2 --> <div class="dd-col col-3"> <div class="dd-cell-phone-reviews dd-wrap"> <ul id="menu-cell-phone-reviews" class="menu-cell-phone-reviews"><li class="menu-4285 first"><a href="/reviews">Cell Phone Reviews</a></li>
<li class="menu-4286"><a href="/tags/news">Cell Phone News</a></li>
<li class="menu-4287"><a href="/tags/head-to-head-reviews">Phone vs Phone</a></li>
<li class="menu-5909"><a href="/videos">Cell Phone Videos</a></li>
<li class="menu-5910 last"><a href="/cell-phone-app-reviews">App Reviews</a></li>
</ul> </div> <!-- dd-cell-phone-reviews --> <div class="dd-phone-resources dd-wrap"> <ul id="menu-phone-resources" class="menu-phone-resources"><li class="menu-4289 first last"><a href="/rankings/smartphones">Official Smartphone Rankings</a></li>
</ul> </div> <!-- /.dd-phone-resources --> </div> <!-- /.col-3 --> </div> <!-- /.dropdown-col-container --> </div> <!-- /.dropdown-pads --> </div> <!-- /.nav-dropdown-1 --> <div class="nav-dropdown nav-dropdown-2"> <div class="dropdown-pads clearfix"> <div class="dropdown-col-container"> <div class="dd-col"> <div class="dd-home-phone dd-wrap"> <ul id="menu-dropd-business-phone" class="menu-dropd-business-phone"><li class="menu-8678 first last"><a href="/voice-over-ip">VoIP</a></li>
</ul> </div> <!-- /.dd-home-phone --> </div> <!-- /.dd-col --> </div> <!-- /.dropdown-col-container --> </div> <!-- /.dropdown-pads --> </div> <div class="nav-dropdown nav-dropdown-3"> <div class="dropdown-pads clearfix"> <div class="dropdown-col-container"> <div class="dd-col"> <div class="dd-home-phone dd-wrap"> <ul id="menu-dropd-home-phone" class="menu-dropd-home-phone"><li class="menu-7808 first"><a href="/long-distance">Long Distance</a></li>
<li class="menu-8707 last"><a href="/compare-home-phone-service">Residential VoIP</a></li>
</ul> </div> <!-- /.dd-home-phone --> </div> <!-- /.dd-col --> </div> <!-- /.dropdown-col-container --> </div> <!-- /.dropdown-pads --> </div> <!-- /.nav-dropdown-3 --> <div class="nav-dropdown nav-dropdown-4"></div> <div class="nav-dropdown nav-dropdown-5"></div> <div class="nav-dropdown nav-dropdown-6"> <div class="dropdown-pads clearfix"> <div class="dropdown-col-container"> <div class="dd-col"> <div class="dd-home-phone dd-wrap"> <ul id="menu-dropdown-cell-phone-smartph" class="menu-dropdown-cell-phone-smartph"><li class="menu-9973 first last"><a href="/holiday-cell-phone-smartphone-deals">Holiday Deals</a></li>
</ul> </div> <!-- /.dd-home-phone --> </div> <!-- /.dd-col --> </div> <!-- /.dropdown-col-container --> </div> <!-- /.dropdown-pads --> </div> </div> <!-- /.dropdown-menu-container --> </div> <!-- /.header-top --> <div class="header-bottom"> <div class="social-trending clearfix"> <div class="trending-tags"> <label>Trending: </label> <ul class="menu-trending-topics"><li class="menu-10478 first"><a href="/products/apple-iphone-11">iPhone 11</a></li>
<li class="menu-8722"><a href="/products/apple-iphone-11-pro-max">iPhone 11 Pro Max</a></li>
<li class="menu-10939"><a href="/tags/google">Google</a></li>
<li class="menu-10968 last"><a href="/tags/google-pixel-4">Pixel 4</a></li>
</ul> </div> <div class="account-links"> <ul class="user-links"> <li class="first"><a href="/user/login?destination=node/106083">Login</a></li><li class="last register-btn"><a href="/user/register?destination=node/106083">Register</a></li> </ul> <div class="search-button"> <span class="search-icon">Search</span> <div class="searchbar"><form class="search-form" action="/search/node" method="post" id="search-form" accept-charset="UTF-8"><div><div class="container-inline form-wrapper" id="edit-basic"><div class="form-item form-type-textfield form-item-keys"> <label for="edit-keys">Enter your keywords </label> <input type="text" id="edit-keys" name="keys" value="" size="40" maxlength="255" class="form-text" />
</div>
<input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-VVQiBXRIci0zHbzyFFQ5LTt2QS_jqljz0ng6_p9cQ-k" />
<input type="hidden" name="form_id" value="search_form" />
</div></form></div> </div> <div class="social-media-icons social-desktop"> <ul class="clearfix"> <li class="ico fb first"> <span class="icon">f</span> <div class="facebook box"> <div class="content"> <div class="fb-like" data-href="https://www.facebook.com/phonedog" data-layout="standard" data-action="like" data-show-faces="false" data-share="false"></div> </div> </div> </li> <li class="ico tw"> <span class="icon">t</span> <div class="twitter box"> <div class="content"> <a class="twitter-follow-button" href="https://twitter.com/phonedog" data-show-count="false" data-lang="en"> Follow @phonedog </a> <script type="text/javascript"> window.twttr = (function (d, s, id) { var t, js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src= "https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs); return window.twttr || (t = { _e: [], ready: function (f) { t._e.push(f) } });
                    }(document, "script", "twitter-wjs")); </script> </div> </div> </li> <li class="ico yt last"> <span class="icon">yt</span> <div class="youtube box"> <div class="content"> <div class="g-ytsubscribe" data-channel="phonedog" data-channelid="UCsW36751Gy-EAbHQwe9WBNw" data-layout="default" data-count="default"></div> </div> </div> </li> </ul> </div> <!-- /.social-media-icons /.social-desktop --> <div class="social-media-icons social-mobile"> <a class="icon facebook" onclick="window.open('https://www.facebook.com/phonedog','name','width=450,height=600')">&nbsp;</a> <a class="icon twitter" onclick="window.open('https://twitter.com/intent/user?screen_name=phonedog','name','width=450,height=600')">&nbsp;</a> <a class="icon youtube-two" onclick="window.open('https://www.youtube.com/subscription_center?add_user=phonedog','name','width=450,height=600')">&nbsp;</a> <!-- <a class="icon reddit" href="https://reddit.com/submit?url=https://www.phonedog.com&title=PhoneDogAre you interested in Samsung&#039;s XCover Pro?" target="_blank">&nbsp;</a> --> <!-- <a class="icon linkedin" onclick="window.open('https://www.linkedin.com/company/follow/submit?id=3142054','name','width=450,height=600')">&nbsp;</a> --> <!-- <a class="icon email" href="mailto:?Subject=PhoneDog&Body=I%20saw%20this%20and%20thought%20of%20you!%20 https://www.phonedog.com">&nbsp;</a> --> </div> <!-- /.social-media-icons /.social-mobile --> </div> <!-- /.account-links --> </div> <!-- /.social-trending --> </div> <!-- /.header-bottom -->
</header>
<div id="rootContainer"> <div class="body-content"> <div class="row"> <div class="large-8 medium-12 small-12 columns content-left"><!--CONTENT--> <div class="row"> <div id="top-ads" class="row sponsors sponsor-970"> <div class="section"> <div class="region region-top-ads "> <div id="block-common-core-voip-top-banner" class="block block-common-core" > <div class="content"> <div id="top-slot"></div> </div>
</div> </div> </div> </div><!-- /.section, /#sidebar-first --> <div class="large-12 columns"> <section id="content"> <h1 class="title" id="page-title"> Are you interested in Samsung&#039;s XCover Pro? </h1> <!-- tabs --> <div class="home-columns clearfix"> </div> <div class="region region-content content"> <div class="first-term-header-tag"><a href="/tags/samsung">Samsung</a></div> <div class="editor-block"> <div class="author-foto"> <img src="https://www.phonedog.com/sites/phonedog.com/files/pictures/picture-300797-1415231581.jpg" /> </div> <div class="author-content"> <div class="row"> <div class="large-7 columns"> <span class="author-name"><a href="/authors/EvanPSelleck">Evan Selleck</a></span><div class="author-info"><span class="author-title">Contributing Editor</span></div> <div class="author-tw"> <a href="https://www.twitter.com/PhoneDog_Evan" target="_blank" rel="no_follow" title="&#64;PhoneDog_Evan on Twitter"> <img src="/sites/phonedog.com/themes/phonedog/images/icons/icon-tw-blue.png" /> </a> </div> </div> <div class="large-5 columns text-right"> <span class="author-separator"> | </span><span class="author-published-date">January 13, 2020</span> <div class="total-shares single-post" style="cursor: pointer;">0 shares <div class="social-shares-breakdown hidden"> <div class="social-breakdown facebook-breakdown icon">0</div> <div class="social-breakdown twitter-breakdown icon">0</div> <div class="social-breakdown disqus-breakdown">0</div> <div class="social-breakdown linkedin-breakdown icon">0</div> <div class="social-breakdown reddit-breakdown icon">0</div> <div class="social-breakdown whatsapp-breakdown icon">0</div> <div class="social-breakdown sms-breakdown icon">0</div> <div class="social-breakdown share-by-email-breakdown icon">0</div> </div> </div> </div> </div> </div> </div>
<div id="share-106083" class="blogshare"> <a class="icon facebook social-share-both" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro','name','width=450,height=600,titlebar=no,menubar=no,toolbar=no')">&nbsp;</a> <a class="icon twitter social-share-both" onclick="window.open('https://twitter.com/share?url=https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro&text=Are you interested in Samsung's XCover Pro?','name','width=450,height=600,titlebar=no,menubar=no,toolbar=no')">&nbsp;</a> <a class="icon sms social-share-mobile ios-vs-android" data-href="sms:;body=Phonedog.com: Are you interested in Samsung's XCover Pro? https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro">&nbsp;</a> <a class="icon whatsapp social-share-mobile wa_btn wa_btn_l" width="10" height="10" style="width: 10px; height: 10px; background-position: 7px 7px; padding: 5px 11px 8px 7px;" href="whatsapp://send" data-text="I saw this on Phonedog.com and thought of you! Are you interested in Samsung's XCover Pro?" data-href="https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro"></a> <a class="icon reddit social-share-desktop" onclick="window.open('https://reddit.com/submit?url=https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro&title=Are you interested in Samsung's XCover Pro?','name','width=450,height=600,titlebar=no,menubar=no,toolbar=no')">&nbsp;</a> <a class="icon linkedin social-share-desktop" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro','name','width=450,height=600,titlebar=no,menubar=no,toolbar=no')">&nbsp;</a> <a class="icon share-by-email social-share-both" href="mailto:?Subject=Phonedog.com: Are you interested in Samsung's XCover Pro?&Body=I saw this on Phonedog.com and thought of you! https://www.phonedog.com/2020/01/13/are-you-interested-samsungs-xcover-pro">&nbsp;</a>
</div> <!-- /.blogshare --> <div id="node-106083" class="node node-blog node-promoted blog-entry clearfix"> <div class="content"> <div class="field field-name-field-blog-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/blog_entry/public/blog/main_image/2020/01/galaxy-xcover-pro-official_0.jpg?itok=ffFgmHY_" width="728" height="600" alt="Samsung XCover Pro" /></div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"><p>There might not be as many of them today as there used to be, but rugged phones are still a thing. Samsung used to be one of the companies out there in the wild releasing new tough handsets on a regular basis, so it's not really a surprise to see the company coming back with a new idea in 2020.</p>
<p>Samsung <a href="https://www.phonedog.com/2020/01/12/samsung-galaxy-xcover-pro-official-specs-launch">recently unveiled</a> what it calls the "XCover Pro," and it brings with it the now familiar design of its more flagship handsets, but packs it all in a rugged package. The handset can survive a fall from 1.5 meters without a case, and it can also survive in environments with extreme altitude and humidity, among other conditions.</p>
<p>It's not the most eye-catching design out there, but it's also not the worst.</p>
<p>The XCover Pro features a fingerprint reader on the side of the handset (so no in-display fingerprint scanner this time), two cameras on the back, a hole-punch display, and a microSD card slot for expandable storage. It comes with 4GB of RAM and 64GB of built-in storage. The screen measures in at 6.3 inches.</p>
<p>It's a pretty mid-range handset, all things considered, but that's not necessarily a bad thing. It definitely looks good enough, at least on paper. Plus, it's running Android 10 out of the box, so that's a nice touch.</p>
<p>But what's probably most important about the XCover Pro is the fact that the 4050mAh battery is user replaceable. That's right, Samsung has brought back the removable battery! This used to be one of the primary features for Samsung-branded handsets, with the company using it as a major selling point against the likes of Apple's iPhones for years.</p>
<p>Of course, Samsung moved away from the removable battery, too, but it looks like the company's not ready to completely give up on the idea just yet. But the question is, of course, is this a feature people want anymore?</p>
<p>The reason behind a removable battery is pretty clear: it's quick to swap out in a pinch. So if you have an extra battery and you need to replace the dead one in your phone, you can. I can't say that I've ever done something like that -- having an extra battery on me, even for planned trips, just never panned out. But I know some people who absolutely loved the option, even if they didn't have to take advantage of it all the time.</p>
<p>So, with Samsung bringing back the removable battery (kind of), I'm curious: Is this something you'd be interested in seeing coming back to more flagship handsets? Would you buy a new Galaxy S smartphone down the line if it had a removable battery? Let me know!</p>
</div></div></div> </div>
</div> <div class="post-tax"> <ul class="related-links"> <li><a href="/tags/samsung">Samsung</a></li><li><a href="/tags/android">Android</a></li><li><a href="/tags/xcover-pro">XCover Pro</a></li><li><a href="/manufacturers/samsung/products">Samsung</a></li></ul> </ul>
</div> <link data-nid="106101" id="infinite-prev-106101" rel="prev" class="infinite-prev-load" href="/2020/01/14/youtube-ios-topics-subscriptions-feed" data-url="/2020/01/14/youtube-ios-topics-subscriptions-feed"><link data-nid="106082" id="infinite-next-106082" rel="next" class="infinite-next-load" href="/2020/01/13/galaxy-z-flip-samsung-clamshell-foldable-name" data-url="/2020/01/13/galaxy-z-flip-samsung-clamshell-foldable-name"><input class="disqus_comment_count" type="hidden" value="0"> </div> <div class="yieldmo ym-content clearfix"> <div id="ym_672857824456023928" class="ym"></div><script type="text/javascript">(function(e,t){if(t._ym===void 0){t._ym="";var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.min.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)}else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);</script> </div> <div id="content-bottom" class="clearfix"> <div id="block-phonedog-phonedog-prev-next" class="block block-phonedog" > <div class="content"> <div class="prev-article"><a href="/2020/01/13/samsung-galaxy-s20-ultra-5g-specs-leak"> <div class="prev-img"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/related_product/public/blog/featured_image/2020/01/samsung-title_3.jpg?itok=HYwAn6XL" alt="" /></div><div class="prev-link"><span>Previous Article</span>Samsung Galaxy S20 Ultra 5G specs leak, including 5000mAh battery</div></a></div><div class="next-article"><a href="/2020/01/13/galaxy-z-flip-samsung-clamshell-foldable-name"> <div class="next-img"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/related_product/public/blog/featured_image/2020/01/samsung-clamshell-foldable-title.jpg?itok=Vv9D7j2f" alt="" /></div><div class="next-link"><span>Next Article</span>Galaxy Z Flip may be the name of Samsung clamshell foldable</div></a></div> </div>
</div><div id="block-phonedog-phonedog-remember-to-vote" class="block block-phonedog" > <div class="content"> <div id="remember-to-vote"> <div class="remember-img"><a href="/rankings/smartphones"><img src="/sites/all/modules/custom/phonedog/images/logo-smartphone-rankings.png" /></a></div> <div class="remember-info"> <p><a href="/rankings/smartphones"><strong>Don't forget to VOTE!</strong> Each week, PhoneDog Fans vote for their #1 smartphone in the Official Smartphone Rankings. Vote now and contribute to the industry's most relevant weekly ranking charts.</a></p> </div> </div> </div>
</div><div id="block-common-core-rel-blog-image" class="block block-common-core" > <h2 >Related Posts</h2> <div class="content"> <ul class="related-blog-wrapper"><li><a href="/2020/01/13/samsung-galaxy-s20-ultra-5g-specs-leak"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/blog_entry_block_views/public/blog/featured_image/2020/01/samsung-title_3.jpg?itok=mveUxCeU"/></a><span><a href="/2020/01/13/samsung-galaxy-s20-ultra-5g-specs-leak">Samsung Galaxy S20 Ultra 5G specs leak, including 5000mAh battery</a></span></li><li><a href="/2020/01/13/nearby-sharing-google-airdrop-android"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/blog_entry_block_views/public/blog/featured_image/2020/01/android-title.jpg?itok=wJLOjnro"/></a><span><a href="/2020/01/13/nearby-sharing-google-airdrop-android">Nearby Sharing leaks as new name for Google&#039;s AirDrop-style Android sharing feature</a></span></li><li><a href="/2020/01/13/samsung-galaxy-s20-plus-camera-features"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/blog_entry_block_views/public/blog/featured_image/2020/01/samsung-ces-title.jpg?itok=HEowC2Ls"/></a><span><a href="/2020/01/13/samsung-galaxy-s20-plus-camera-features">Samsung Galaxy S20+ leaks continue as more camera details come out</a></span></li><li><a href="/2020/01/14/poco-f2-trademark-xiaomi-pocophone"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/blog_entry_block_views/public/blog/featured_image/2020/01/poco-xiaomi-title.jpg?itok=iroswFVE"/></a><span><a href="/2020/01/14/poco-f2-trademark-xiaomi-pocophone">Poco F2 trademark hints that Xiaomi may launch new Pocophone soon</a></span></li></ul> </div>
</div><div id="block-taboola-taboola-below-article" class="block block-taboola" > <div class="content"> <div id="taboola-below-article-thumbnails"></div> <script type="text/javascript"> window._taboola = window._taboola || []; _taboola.push({ mode: 'thumbnails-b', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type: 'mix' 
           }); </script> </div>
</div><div class="block block-disqus" data-nid="106083" data-url="/2020/01/13/are-you-interested-samsungs-xcover-pro" > <div class="content"> <div id="disqus_thread"><noscript><p><a href="http://phonedogwww.disqus.com/?url=https%3A%2F%2Fwww.phonedog.com%2F2020%2F01%2F13%2Fare-you-interested-samsungs-xcover-pro">View the discussion thread.</a></p></noscript></div> </div>
</div><div id="block-phonedog-phonedog-pd-728-90-b" class="block block-phonedog" > <div class="content"> <!-- /41014381/PhoneDog/PD_728x90_B --><div class="show-for-medium-up" id="dfp-gpt-ad-728x90-b" style="height:90px; width:728px; margin: auto; "><script type="text/javascript">googletag.cmd.push(function() {googletag.display("dfp-gpt-ad-728x90-b"); });</script></div> </div>
</div> </div> </section><!-- #content --> </div> </div> </div> <!--Sidebar--> <div class="large-4 medium-12 small-12 columns content-sidebar"> <div class="region region-sidebar-right "> <div id="block-views-plans-sidebar-plantool-four" class="block block-views phone-tool-wrap" > <div class="content"> <div class="view view-plans view-id-plans view-display-id-sidebar_plantool_four tool plan-tool sidebar-plan-tool version-four view-dom-id-4eb79d80a304ad025e97736e69307f51"> <div class="view-filters"> <form action="/wireless_plans/feed" method="get" id="views-exposed-form-plans-sidebar-plantool-four" accept-charset="UTF-8"><div><div class="views-exposed-form"> <h2><img src="/sites/all/modules/features/phone_and_plan/images/sidebar-tool-header.png" alt="" /></h2> <div class="views-exposed-widgets clearfix"> <div class="col select-a-phone"> <div id="select-a-phone" class="views-exposed-widget views-widget-filter-edit-field-select-a-phone"> <label>Select a phone:<br /><span>(optional)</span></label> <div class="phone-select"><span>+</span></div> </div> <div id="selected-phone"></div> <div id="phone-overlay" class="overlay"></div> <div id="edit-field-associated-plans-nid-wrapper" class="views-exposed-widget views-widget-filter-edit-field-associated-plans-nid"> <div class="views-widget"> <input type="hidden" name="field_associated_plans_nid" value="All" /> <input type="hidden" class="exposed_input" name="selected_phone_field" id="selected_phone_field" value=""> <input type="hidden" class="exposed_input" name="selected_phone_image_field" id="selected_phone_image_field" value=""> </div> </div> </div> <div class="col checkboxes"> <div id="-wrapper" class="views-exposed-widget views-widget-filter-"> <div class="views-widget"> </div> </div> <div id="edit-additional-lines-wrapper" class="views-exposed-widget views-widget-filter-edit-additional-lines"> <label for="edit-additional-lines"> Number of Lines: </label> <div class="views-widget"> <div id="edit-additional-lines" class="form-radios bef-select-as-radios"><div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-all" name="additional_lines" value="All" /> <label class="option" for="edit-additional-lines-all">- Any - </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-1" name="additional_lines" value="1" checked="checked" /> <label class="option" for="edit-additional-lines-1">1 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-2" name="additional_lines" value="2" /> <label class="option" for="edit-additional-lines-2">2 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-3" name="additional_lines" value="3" /> <label class="option" for="edit-additional-lines-3">3 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-4" name="additional_lines" value="4" /> <label class="option" for="edit-additional-lines-4">4 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-5" name="additional_lines" value="5" /> <label class="option" for="edit-additional-lines-5">5 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-6" name="additional_lines" value="6" /> <label class="option" for="edit-additional-lines-6">6 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-7" name="additional_lines" value="7" /> <label class="option" for="edit-additional-lines-7">7 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-8" name="additional_lines" value="8" /> <label class="option" for="edit-additional-lines-8">8 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-9" name="additional_lines" value="9" /> <label class="option" for="edit-additional-lines-9">9 </label> </div>
<div class="form-item form-type-radio form-item-additional-lines"> <input class="bef-select-as-radios form-radio" type="radio" id="edit-additional-lines-10" name="additional_lines" value="10" /> <label class="option" for="edit-additional-lines-10">10 </label> </div>
</div> </div> </div> </div> <div class="col sliders clearfix"> <div id="edit-field-talk-minutes-value-wrapper" class="views-exposed-widget views-widget-filter-edit-field-talk-minutes-value clearfix"> <label for="edit-field-talk-minutes-value"> <span class="minutes-value"></span> <span class="label">Minutes</span> </label> <div class="views-widget"> <div class="form-item form-type-textfield form-item-field-talk-minutes-value"> <input type="text" id="edit-field-talk-minutes-value" name="field_talk_minutes_value" value="1000" size="30" maxlength="128" class="form-text" />
</div> </div> </div> <div id="edit-field-messages-wrapper" class="views-exposed-widget views-widget-filter-edit-field-messages-value"> <label for="edit-field-messages-value"> <span class="messages-value">500</span> <span class="label">Messages</span> </label> <div class="views-widget"> <input type="text" value="500" name="messages" id="edit-field-messages-value" /> </div> </div> <div id="edit-field-plan-data-value-wrapper" class="views-exposed-widget views-widget-filter-edit-field-plan-data-value"> <label for="edit-field-plan-data-value"> <span class="data-value"></span> <span class="label">Data</span> <span class="icon-info"></span> <div class="tooltip"> <div class="content"> <p>Select the amount of total data you need for the entire plan.</p> <p>For example, if you need 2 lines with 1 GB of data each, you would select 2 GB of data with the data slider below.</p> </div> </div> </label> <div class="views-widget"> <div class="form-item form-type-select form-item-field-plan-data-value"> <select id="edit-field-plan-data-value" name="field_plan_data_value" class="form-select"><option value="All">- Any -</option><option value="0">0</option><option value="5">5KB</option><option value="50">50MB</option><option value="30">30MB</option><option value="100">100MB</option><option value="125">125MB</option><option value="150">150MB</option><option value="200">200MB</option><option value="250">250MB</option><option value="300">300MB</option><option value="334">334MB</option><option value="350">350MB</option><option value="375">375MB</option><option value="400">400MB</option><option value="500" selected="selected">500MB</option><option value="600">600MB</option><option value="625">625MB</option><option value="700">700MB</option><option value="800">800MB</option><option value="834">834MB</option><option value="900">900MB</option><option value="938">938MB</option><option value="1024">1GB</option><option value="1250">1.2GB</option><option value="1536">1.5GB</option><option value="1667">1.6GB</option><option value="2048">2GB</option><option value="2083">2.03GB</option><option value="2560">2.5GB</option><option value="3072">3GB</option><option value="3750">3.7GB</option><option value="4096">4GB</option><option value="5120">5GB</option><option value="6144">6GB</option><option value="6250">6.1GB</option><option value="7168">7GB</option><option value="7500">7.3GB</option><option value="8192">8GB</option><option value="8750">8.5GB</option><option value="9216">9GB</option><option value="10240">10GB</option><option value="11264">11GB</option><option value="12288">12GB</option><option value="13312">13GB</option><option value="14336">14GB</option><option value="15360">15GB</option><option value="16384">16GB</option><option value="18432">18GB</option><option value="20480">20GB</option><option value="22528">22GB</option><option value="23552">23GB</option><option value="24576">24GB</option><option value="25600">25GB</option><option value="30720">30GB</option><option value="32768">32GB</option><option value="35840">35GB</option><option value="40960">40GB</option><option value="51200">50GB</option><option value="61440">60GB</option><option value="75000">75GB</option><option value="81920">80GB</option><option value="87040">85GB</option><option value="102400">100GB</option><option value="122880">120GB</option><option value="153600">150GB</option><option value="204800">200GB</option><option value="512000">Unlimited</option></select>
</div> </div> </div> </div> <div class="col sidebar-plan-content results"> <div class="count-components clearfix"> <div class="count" id="plan-count"><span>-</span> <span>Plans</span></div> <input type="submit" id="plan-submit" value="Show my plans" /> </div> </div> <div class="col views-submit-button"> <input type="submit" id="edit-submit-plans" name="" value="Apply" class="form-submit" /> </div> </div> <span class="divider"><img src="/sites/all/modules/features/phone_and_plan/images/sidebar-plantool-divider.png" alt="____________________" /></span>
</div></div></form> </div> </div> </div>
</div>
<div id="block-common-core-voip-sidead-banner" class="block block-common-core" > <div class="content"> <div id="side-slot"></div> </div>
</div><div id="block-phonedog-phonedog-pd-300-250-a" class="block block-phonedog" > <div class="content"> <!-- /41014381/PhoneDog/PD_300x250_A --><div id="dfp-gpt-ad-300x250-a"><script type="text/javascript">googletag.cmd.push(function() { googletag.display("dfp-gpt-ad-300x250-a"); });</script></div> </div>
</div><div id="block-phonedog-phonedog-pd-300-250-b" class="block block-phonedog" > <div class="content"> <!-- /41014381/PhoneDog/PD_300x250_B --><div id="dfp-gpt-ad-300x250-b"><script type="text/javascript">googletag.cmd.push(function() { googletag.display("dfp-gpt-ad-300x250-b"); });</script></div> </div>
</div><div id="block-taboola-taboola-right-sidebar" class="block block-taboola" > <div class="content"> <div id="taboola-right-rail-thumbnails"></div> <script type="text/javascript"> window._taboola = window._taboola || []; _taboola.push({ mode: 'thumbnails-c', container: 'taboola-right-rail-thumbnails', placement: 'Right Rail Thumbnails', target_type: 'mix'
      }); </script> </div>
</div><div id="block-common-core-voip-residential" class="block block-common-core"> <div class="content"> <div id="res-sidetable"></div> </div>
</div><div id="block-phonedog-phonedog-pd-300-250-c" class="block block-phonedog" > <div class="content"> <!-- /41014381/PhoneDog/PD_300x250_C --><div id="dfp-gpt-ad-300x250-c"><script type="text/javascript">googletag.cmd.push(function() { googletag.display("dfp-gpt-ad-300x250-c"); });</script></div> </div>
</div><div id="block-views-block-featured-sidebar" class="block block-views" > <h2 >Featured</h2> <div class="content"> <div class="view view-block view-id-block view-display-id-featured_sidebar view-dom-id-6aa731269fdf732194ebf22f667997b3"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <div class="featured-image"> <a href="/2020/01/12/samsung-galaxy-s20-plus-photos-leak"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/home_exclusives_/public/blog/featured_image/2020/01/galaxy-s20-plus-leak-title.jpg?itok=voqPvIZ-" alt="Galaxy S20 Plus cameras" /></a> </div>
<div class="featured-content"> <div class="fe-title"> <span class="field-content"><a href="/2020/01/12/samsung-galaxy-s20-plus-photos-leak">Samsung Galaxy S20+ shown off in clear hands-on photos</a></span> </div> <div class="user-picture"> <a href="/authors/awagner" title="View user profile."><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/thumbnail/public/pictures/picture-707421-1542867561.jpg?itok=9QQDKXto" alt="Alex Wagner&#039;s picture" title="Alex Wagner&#039;s picture" /></a> </div> <div class="fe-meta"> <p class="author"><a href="/authors/awagner" title="View user profile." class="username">Alex Wagner</a></p><p class="date"><em class="placeholder">2 days 13 hours</em> ago</p> </div> <div class="total-shares sidebar-featured" style="cursor: pointer;"> 2 shares <div class="social-shares-breakdown hidden"> <div class="social-breakdown facebook-breakdown icon">0</div> <div class="social-breakdown twitter-breakdown icon">0</div> <div class="social-breakdown disqus-breakdown">0</div> <div class="social-breakdown reddit-breakdown icon">0</div> <div class="social-breakdown linkedin-breakdown icon">0</div> <div class="social-breakdown whatsapp-breakdown icon">0</div> <div class="social-breakdown sms-breakdown icon">2</div> <div class="social-breakdown share-by-email-breakdown icon">0</div> </div> </div> </div> </div> <div class="views-row views-row-2 views-row-even"> <div class="featured-image"> <a href="/videos/best-smartphones-ces-2020"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/home_exclusives_/public/video_blog/featured_images/2020/01/best-smartphones-ces-2020.jpg?itok=f1ZnSC2D" alt="Best Smartphones At CES 2020!" /></a> <a href="/videos/best-smartphones-ces-2020" class="play-button"> <img src="/sites/phonedog.com/themes/phonedog/images/icons/play-button-outline.png" /> </a> </div>
<div class="featured-content"> <div class="fe-title"> <span class="field-content"><a href="/videos/best-smartphones-ces-2020">Best smartphones at CES 2020!</a></span> </div> <div class="user-picture"> <a href="/authors/BeauHD" title="View user profile."><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/thumbnail/public/pictures/picture-358876-1504166913.jpg?itok=C98kfMt3" alt="Beau Hamilton&#039;s picture" title="Beau Hamilton&#039;s picture" /></a> </div> <div class="fe-meta"> <p class="author"><a href="/authors/BeauHD" title="View user profile." class="username">Beau Hamilton</a></p><p class="date"><em class="placeholder">4 days 8 hours</em> ago</p> </div> </div> </div> <div class="views-row views-row-3 views-row-odd"> <div class="featured-image"> <a href="/2020/01/04/samsung-unpacked-february-11-galaxy-s20-fold-clamshell"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/home_exclusives_/public/blog/featured_image/2020/01/samsung-galaxy-unpacked-title.jpg?itok=i8wE13Ck" alt="Samsung Galaxy Unpacked event" /></a> </div>
<div class="featured-content"> <div class="fe-title"> <span class="field-content"><a href="/2020/01/04/samsung-unpacked-february-11-galaxy-s20-fold-clamshell">Samsung Unpacked officially scheduled for February 11, Galaxy S20 expected </a></span> </div> <div class="user-picture"> <a href="/authors/awagner" title="View user profile."><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/thumbnail/public/pictures/picture-707421-1542867561.jpg?itok=9QQDKXto" alt="Alex Wagner&#039;s picture" title="Alex Wagner&#039;s picture" /></a> </div> <div class="fe-meta"> <p class="author"><a href="/authors/awagner" title="View user profile." class="username">Alex Wagner</a></p><p class="date"><em class="placeholder">1 week 3 days</em> ago</p> </div> </div> </div> <div class="views-row views-row-4 views-row-even views-row-last"> <div class="featured-image"> <a href="/videos/motorola-one-hyper-unboxing-and-first-impressions"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/home_exclusives_/public/video_blog/featured_images/2019/12/motorola-one-hyper-unboxing.jpg?itok=VoBjGtND" alt="Motorola One Hyper Unboxing and First Impressions" /></a> <a href="/videos/motorola-one-hyper-unboxing-and-first-impressions" class="play-button"> <img src="/sites/phonedog.com/themes/phonedog/images/icons/play-button-outline.png" /> </a> </div>
<div class="featured-content"> <div class="fe-title"> <span class="field-content"><a href="/videos/motorola-one-hyper-unboxing-and-first-impressions">Motorola One Hyper unboxing and first impressions</a></span> </div> <div class="user-picture"> <a href="/authors/BeauHD" title="View user profile."><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/thumbnail/public/pictures/picture-358876-1504166913.jpg?itok=C98kfMt3" alt="Beau Hamilton&#039;s picture" title="Beau Hamilton&#039;s picture" /></a> </div> <div class="fe-meta"> <p class="author"><a href="/authors/BeauHD" title="View user profile." class="username">Beau Hamilton</a></p><p class="date"><em class="placeholder">2 weeks 5 days</em> ago</p> </div> <div class="total-shares sidebar-featured" style="cursor: pointer;"> 2 shares <div class="social-shares-breakdown hidden"> <div class="social-breakdown facebook-breakdown icon">0</div> <div class="social-breakdown twitter-breakdown icon">0</div> <div class="social-breakdown disqus-breakdown">0</div> <div class="social-breakdown reddit-breakdown icon">0</div> <div class="social-breakdown linkedin-breakdown icon">0</div> <div class="social-breakdown whatsapp-breakdown icon">0</div> <div class="social-breakdown sms-breakdown icon">2</div> <div class="social-breakdown share-by-email-breakdown icon">0</div> </div> </div> </div> </div> </div> <div class="view-footer"> <p><a href="/posts/featured">More Featured Articles</a></p> </div> </div> </div>
</div><div id="block-views-ranking-block" class="block block-views" > <h2 >Official Smartphone Rankings</h2> <div class="content"> <div class="view view-ranking view-id-ranking view-display-id-block view-dom-id-3e9ccce00dd9f3e3411f3eef203b0d89"> <ul class="tabs-menu"> <li class="current"><a href="#tab-1">People's Choice</a></li> <li><a href="#tab-2">Expert's Choice</a></li> </ul> <div class="tab"> <div class="view-content tab-content" id="tab-1"> <div class="views-row views-row-1 views-row-odd views-row-first views-row-last"> <div class='feature-image'><a href="/products/samsung-galaxy-note-10-0"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/phone_ranking_thumbnail/public/phone/large/samsung-galaxy-note-10%2B-silver.png?itok=zr9cnzGG" alt="" /></a></div><div class="rank-content"> <div class='title'><span class="field-content"><a href="/products/samsung-galaxy-note-10-0">Samsung Galaxy Note 10+</a></span></div><div class='vote-count'>1&nbsp;Votes </div><div class="vote-now vote-processed unregistered-vote"> <span class="flag-wrapper flag-ranking-vote"> <a href="#" data-reveal-id="voteModal" title="Vote for this phone ranking." class="flag flag-action flag-link-toggle flag-processed" rel="nofollow">Vote Now</a> <span class="flag-throbber">&nbsp;</span> </span> </div><div class="unregistered-vote-box reveal-modal" id="voteModal" data-reveal> <div class="modal-banner"> <div class="modal-dog"> <img src="/sites/phonedog.com/themes/phonedog/images/button/vote-banner.png" /> </div> <div class="modal-login"> <h1>OFFICIAL SMARTPHONE RANKINGS</h1> <h2>Please Login/Register to Vote</h2><a href="/user/register?cpath=2020/01/13/are-you-interested-samsungs-xcover-pro"><img src="/sites/phonedog.com/themes/phonedog/images/button/login.png" /></a> <a href="/user/simple-fb-connect?destination=2020/01/13/are-you-interested-samsungs-xcover-pro" class=""><img src="/sites/phonedog.com/themes/phonedog/images/button/fb-button.png" /></a> </div> </div> <a class="close-reveal-modal">&#215;</a> </div></div> </div> </div> <div class="attachment attachment-after tab-content" id="tab-2"> <div class="view view-ranking view-id-ranking view-display-id-attachment_2"> </div> </div> </div> <div class="view-footer"> <p><a href="/rankings/smartphones">More People's Choice</a></p> </div> </div> </div>
</div><div id="block-views-block-block-4" class="block block-views" > <h2 >Latest Videos</h2> <div class="content"> <div class="view view-block view-id-block view-display-id-block_4 view-dom-id-3eeba1e1f304e1d6bfbdad4c710ccacb"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <div class="featured-image"> <a href="/videos/blu-vivo-x5-unboxing-and-first-look"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/latest_videos_/public/video_blog/featured_images/2019/09/blu-vivo-x5-unboxing-and-first-look.jpg?itok=Hm2AaO60" width="300" height="130" alt="BLU Vivo X5 unboxing and first look" /></a> <a href="/videos/blu-vivo-x5-unboxing-and-first-look" class="play-button"> <img src="/sites/phonedog.com/themes/phonedog/images/icons/play-button-outline.png" class="play-button" /> </a>
</div>
<div class="featured-content"> <h5 class="post-title"><a href="/videos/blu-vivo-x5-unboxing-and-first-look">BLU Vivo X5 unboxing and first look</a></h5></div>
<div class="total-shares sidebar-featured" style="cursor: pointer;"> 8 shares <div class="social-shares-breakdown hidden"> <div class="social-breakdown facebook-breakdown icon">0</div> <div class="social-breakdown twitter-breakdown icon">0</div> <div class="social-breakdown disqus-breakdown">0</div> <div class="social-breakdown reddit-breakdown icon">0</div> <div class="social-breakdown linkedin-breakdown icon">0</div> <div class="social-breakdown whatsapp-breakdown icon">2</div> <div class="social-breakdown sms-breakdown icon">2</div> <div class="social-breakdown share-by-email-breakdown icon">4</div> </div>
</div> </div> <div class="views-row views-row-2 views-row-even"> <div class="featured-image"> <a href="/videos/bold-n1-impressions-flagship-specs-aggressive-price"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/latest_videos_/public/video_blog/featured_images/2019/09/bold-n1-first-impressions.jpg?itok=l6frB3Pc" width="300" height="130" alt="BOLD N1 Impressions: Flagship Specs With Aggressive Price!" /></a> <a href="/videos/bold-n1-impressions-flagship-specs-aggressive-price" class="play-button"> <img src="/sites/phonedog.com/themes/phonedog/images/icons/play-button-outline.png" class="play-button" /> </a>
</div>
<div class="featured-content"> <h5 class="post-title"><a href="/videos/bold-n1-impressions-flagship-specs-aggressive-price">BOLD N1 impressions: Flagship specs with aggressive price!</a></h5></div>
<div class="total-shares sidebar-featured" style="cursor: pointer;"> 7 shares <div class="social-shares-breakdown hidden"> <div class="social-breakdown facebook-breakdown icon">0</div> <div class="social-breakdown twitter-breakdown icon">0</div> <div class="social-breakdown disqus-breakdown">0</div> <div class="social-breakdown reddit-breakdown icon">0</div> <div class="social-breakdown linkedin-breakdown icon">0</div> <div class="social-breakdown whatsapp-breakdown icon">3</div> <div class="social-breakdown sms-breakdown icon">3</div> <div class="social-breakdown share-by-email-breakdown icon">1</div> </div>
</div> </div> <div class="views-row views-row-3 views-row-odd views-row-last"> <div class="featured-image"> <a href="/videos/samsung-galaxy-note-10-unboxing-and-first-impressions"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/latest_videos_/public/video_blog/featured_images/2019/08/note-10-unboxing.jpg?itok=bbbthDis" width="300" height="130" alt="Samsung Galaxy Note 10+ Unboxing and First Impressions" /></a> <a href="/videos/samsung-galaxy-note-10-unboxing-and-first-impressions" class="play-button"> <img src="/sites/phonedog.com/themes/phonedog/images/icons/play-button-outline.png" class="play-button" /> </a>
</div>
<div class="featured-content"> <h5 class="post-title"><a href="/videos/samsung-galaxy-note-10-unboxing-and-first-impressions">Samsung Galaxy Note 10+ unboxing and first impressions</a></h5></div>
<div class="total-shares sidebar-featured" style="cursor: pointer;"> 6 shares <div class="social-shares-breakdown hidden"> <div class="social-breakdown facebook-breakdown icon">0</div> <div class="social-breakdown twitter-breakdown icon">0</div> <div class="social-breakdown disqus-breakdown">0</div> <div class="social-breakdown reddit-breakdown icon">0</div> <div class="social-breakdown linkedin-breakdown icon">0</div> <div class="social-breakdown whatsapp-breakdown icon">4</div> <div class="social-breakdown sms-breakdown icon">1</div> <div class="social-breakdown share-by-email-breakdown icon">1</div> </div>
</div> </div> </div> <div class="view-footer"> <p><a href="/videos">More Videos</a></p> </div> </div> </div>
</div> </div> </div> <!--END SIDEBAR--> </div> </div><!--END BODYCONTENT--> <!--Page Bottom--> <div class="row" id="bottom-page-wrapper"> <div class="large-12 columns"> <div id="page-bottom" class="clearfix"> <div class="region region-body-bottom "> <div id="block-phonedog-phonedog-pd-728-90-c" class="block block-phonedog" > <div class="content"> <!-- /41014381/PhoneDog/PD_728x90_C --><div class="show-for-medium-up" id="dfp-gpt-ad-728x90-c" style="height:90px; width:728px; margin: auto; "><script type="text/javascript">googletag.cmd.push(function() {googletag.display("dfp-gpt-ad-728x90-c"); });</script></div> </div>
</div><div id="block-views-ranking-block-1" class="block block-views" > <h2 >This Week&#039;s &quot;People&#039;s Choice Rankings&quot; Best Smartphone</h2> <div class="content"> <div class="view view-ranking view-id-ranking view-display-id-block_1 view-dom-id-360a520cbbb10abfe64ca63d67ad4487"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <span class="medals">&nbsp;</span>
<div class='feature-image'><a href="https://www.phonedog.com/products/samsung-galaxy-note-10-0" rel="follow"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/this_weeks_best/public/phone/large/samsung-galaxy-note-10%2B-silver.png?itok=f8ea3qlU" width="65" height="101" /></a></div><div class="rank-content"> <div class='title'><span class="field-content"><a href="/products/samsung-galaxy-note-10-0">Samsung Galaxy Note 10+</a></span></div><div class='phone-info'><div class="vote-now vote-processed unregistered-vote"> <span class="flag-wrapper flag-ranking-vote"> <a href="#" data-reveal-id="voteModal" title="Vote for this phone ranking." class="flag flag-action flag-link-toggle flag-processed" rel="nofollow">Vote Now</a> <span class="flag-throbber">&nbsp;</span> </span> </div><div class="unregistered-vote-box reveal-modal" id="voteModal" data-reveal> <div class="modal-banner"> <div class="modal-dog"> <img src="/sites/phonedog.com/themes/phonedog/images/button/vote-banner.png" /> </div> <div class="modal-login"> <h1>OFFICIAL SMARTPHONE RANKINGS</h1> <h2>Please Login/Register to Vote</h2><a href="/user/register?cpath=2020/01/13/are-you-interested-samsungs-xcover-pro"><img src="/sites/phonedog.com/themes/phonedog/images/button/login.png" /></a> <a href="/user/simple-fb-connect?destination=2020/01/13/are-you-interested-samsungs-xcover-pro" class=""><img src="/sites/phonedog.com/themes/phonedog/images/button/fb-button.png" /></a> </div> </div> <a class="close-reveal-modal">&#215;</a> </div></div></div> </div> <div class="views-row views-row-2 views-row-even"> <span class="medals">&nbsp;</span>
<div class='feature-image'><a href="https://www.phonedog.com/products/apple-iphone-xs-max" rel="follow"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/this_weeks_best/public/phone/large/apple-iphone-xs-max-gray.png?itok=S4Ic3Ju1" width="65" height="114" alt="" /></a></div><div class="rank-content"> <div class='title'><span class="field-content"><a href="/products/apple-iphone-xs-max">Apple iPhone Xs Max</a></span></div><div class='phone-info'><div class="vote-now vote-processed unregistered-vote"> <span class="flag-wrapper flag-ranking-vote"> <a href="#" data-reveal-id="voteModal" title="Vote for this phone ranking." class="flag flag-action flag-link-toggle flag-processed" rel="nofollow">Vote Now</a> <span class="flag-throbber">&nbsp;</span> </span> </div><div class="unregistered-vote-box reveal-modal" id="voteModal" data-reveal> <div class="modal-banner"> <div class="modal-dog"> <img src="/sites/phonedog.com/themes/phonedog/images/button/vote-banner.png" /> </div> <div class="modal-login"> <h1>OFFICIAL SMARTPHONE RANKINGS</h1> <h2>Please Login/Register to Vote</h2><a href="/user/register?cpath=2020/01/13/are-you-interested-samsungs-xcover-pro"><img src="/sites/phonedog.com/themes/phonedog/images/button/login.png" /></a> <a href="/user/simple-fb-connect?destination=2020/01/13/are-you-interested-samsungs-xcover-pro" class=""><img src="/sites/phonedog.com/themes/phonedog/images/button/fb-button.png" /></a> </div> </div> <a class="close-reveal-modal">&#215;</a> </div></div></div> </div> <div class="views-row views-row-3 views-row-odd"> <span class="medals">&nbsp;</span>
<div class='feature-image'><a href="https://www.phonedog.com/products/samsung-galaxy-note-9" rel="follow"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/this_weeks_best/public/phone/large/samsung-galaxy-note-9-black.png?itok=hJ0yZMd_" width="65" height="102.5" /></a></div><div class="rank-content"> <div class='title'><span class="field-content"><a href="/products/samsung-galaxy-note-9">Samsung Galaxy Note 9</a></span></div><div class='phone-info'><div class="vote-now vote-processed unregistered-vote"> <span class="flag-wrapper flag-ranking-vote"> <a href="#" data-reveal-id="voteModal" title="Vote for this phone ranking." class="flag flag-action flag-link-toggle flag-processed" rel="nofollow">Vote Now</a> <span class="flag-throbber">&nbsp;</span> </span> </div><div class="unregistered-vote-box reveal-modal" id="voteModal" data-reveal> <div class="modal-banner"> <div class="modal-dog"> <img src="/sites/phonedog.com/themes/phonedog/images/button/vote-banner.png" /> </div> <div class="modal-login"> <h1>OFFICIAL SMARTPHONE RANKINGS</h1> <h2>Please Login/Register to Vote</h2><a href="/user/register?cpath=2020/01/13/are-you-interested-samsungs-xcover-pro"><img src="/sites/phonedog.com/themes/phonedog/images/button/login.png" /></a> <a href="/user/simple-fb-connect?destination=2020/01/13/are-you-interested-samsungs-xcover-pro" class=""><img src="/sites/phonedog.com/themes/phonedog/images/button/fb-button.png" /></a> </div> </div> <a class="close-reveal-modal">&#215;</a> </div></div></div> </div> <div class="views-row views-row-4 views-row-even"> <span class="medals">&nbsp;</span>
<div class='feature-image'><a href="https://www.phonedog.com/products/samsung-galaxy-s9" rel="follow"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/this_weeks_best/public/phone/large/samsung-galaxy-s9-black.png?itok=UAZQTMi2" width="65" height="136.5" /></a></div><div class="rank-content"> <div class='title'><span class="field-content"><a href="/products/samsung-galaxy-s9">Samsung Galaxy S9</a></span></div><div class='phone-info'><div class="vote-now vote-processed unregistered-vote"> <span class="flag-wrapper flag-ranking-vote"> <a href="#" data-reveal-id="voteModal" title="Vote for this phone ranking." class="flag flag-action flag-link-toggle flag-processed" rel="nofollow">Vote Now</a> <span class="flag-throbber">&nbsp;</span> </span> </div><div class="unregistered-vote-box reveal-modal" id="voteModal" data-reveal> <div class="modal-banner"> <div class="modal-dog"> <img src="/sites/phonedog.com/themes/phonedog/images/button/vote-banner.png" /> </div> <div class="modal-login"> <h1>OFFICIAL SMARTPHONE RANKINGS</h1> <h2>Please Login/Register to Vote</h2><a href="/user/register?cpath=2020/01/13/are-you-interested-samsungs-xcover-pro"><img src="/sites/phonedog.com/themes/phonedog/images/button/login.png" /></a> <a href="/user/simple-fb-connect?destination=2020/01/13/are-you-interested-samsungs-xcover-pro" class=""><img src="/sites/phonedog.com/themes/phonedog/images/button/fb-button.png" /></a> </div> </div> <a class="close-reveal-modal">&#215;</a> </div></div></div> </div> <div class="views-row views-row-5 views-row-odd views-row-last"> <span class="medals">&nbsp;</span>
<div class='feature-image'><a href="https://www.phonedog.com/products/blackberry-motion" rel="follow"><img src="https://www.phonedog.com/sites/phonedog.com/files/styles/this_weeks_best/public/phone/large/blackberry-motion-black.png?itok=d_RSQFBX" width="65" height="125.5" /></a></div><div class="rank-content"> <div class='title'><span class="field-content"><a href="/products/blackberry-motion">BlackBerry Motion</a></span></div><div class='phone-info'><div class="vote-now vote-processed unregistered-vote"> <span class="flag-wrapper flag-ranking-vote"> <a href="#" data-reveal-id="voteModal" title="Vote for this phone ranking." class="flag flag-action flag-link-toggle flag-processed" rel="nofollow">Vote Now</a> <span class="flag-throbber">&nbsp;</span> </span> </div><div class="unregistered-vote-box reveal-modal" id="voteModal" data-reveal> <div class="modal-banner"> <div class="modal-dog"> <img src="/sites/phonedog.com/themes/phonedog/images/button/vote-banner.png" /> </div> <div class="modal-login"> <h1>OFFICIAL SMARTPHONE RANKINGS</h1> <h2>Please Login/Register to Vote</h2><a href="/user/register?cpath=2020/01/13/are-you-interested-samsungs-xcover-pro"><img src="/sites/phonedog.com/themes/phonedog/images/button/login.png" /></a> <a href="/user/simple-fb-connect?destination=2020/01/13/are-you-interested-samsungs-xcover-pro" class=""><img src="/sites/phonedog.com/themes/phonedog/images/button/fb-button.png" /></a> </div> </div> <a class="close-reveal-modal">&#215;</a> </div></div></div> </div> </div> <div class="view-footer"> <h2>Recent news from our top carriers:</h2> </div> </div> </div>
</div><div id="block-views-carrier-news-block" class="block block-views" > <h2 >AT&amp;T News</h2> <div class="content"> <div class="view view-carrier-news view-id-carrier_news view-display-id-block att-news-block view-dom-id-e0b4459f107fe02073b8817330e2d812"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2020/01/03/att-5g-plus-expands-35-cities">AT&amp;T 5G+ expands, now live in</a></span> </div> </div> <div class="views-row views-row-2 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/27/att-5g-19-cities">AT&amp;T 5G is now live in 19</a></span> </div> </div> <div class="views-row views-row-3 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/18/att-call-validation-protect-stir-shaken">AT&amp;T begins validating</a></span> </div> </div> <div class="views-row views-row-4 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/13/att-low-band-5g-network-10-cities-coverage">AT&amp;T&#039;s low-band 5G</a></span> </div> </div> <div class="views-row views-row-5 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/26/will-5g-be-must-have-feature-your-next-iphone">Will 5G be a must-have feature for</a></span> </div> </div> <div class="views-row views-row-6 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/25/have-you-switched-postpaid-carrier-prepaid-operator">Have you switched from a postpaid</a></span> </div> </div> <div class="views-row views-row-7 views-row-odd views-row-last"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/22/are-you-buying-atts-samsung-galaxy-note-10-5g">Are you buying AT&amp;T&#039;s</a></span> </div> </div> </div> </div> </div>
</div><div id="block-views-carrier-news-block-1" class="block block-views" > <h2 >Sprint News</h2> <div class="content"> <div class="view view-carrier-news view-id-carrier_news view-display-id-block_1 sprint-news-block view-dom-id-3a5ba1df3a77375339c65fbffaf8b4dc"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2020/01/07/virgin-mobile-killed-sprint">Virgin Mobile being killed off by</a></span> </div> </div> <div class="views-row views-row-2 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2020/01/02/sprint-star-wars-galaxy-note-10-android-10-update">Sprint and Star Wars Galaxy Note</a></span> </div> </div> <div class="views-row views-row-3 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/17/sprint-call-screener-scams-robocalls-protection">Sprint Call Screener aims to</a></span> </div> </div> <div class="views-row views-row-4 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/06/sprint-knit-hat-free">Sprint giving free knit hats to</a></span> </div> </div> <div class="views-row views-row-5 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/26/will-5g-be-must-have-feature-your-next-iphone">Will 5G be a must-have feature for</a></span> </div> </div> <div class="views-row views-row-6 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/25/texas-nevada-leave-lawsuit-t-mobile-sprint-merger">Texas and Nevada drop out of</a></span> </div> </div> <div class="views-row views-row-7 views-row-odd views-row-last"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/25/have-you-switched-postpaid-carrier-prepaid-operator">Have you switched from a postpaid</a></span> </div> </div> </div> </div> </div>
</div><div id="block-views-carrier-news-block-2" class="block block-views" > <h2 >T-Mobile News</h2> <div class="content"> <div class="view view-carrier-news view-id-carrier_news view-display-id-block_2 tmobile-news-block view-dom-id-7a7b0a2d8268680a1a0fd05e7383d88d"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/30/t-mobile-galaxy-note-10-plus-android-10-one-ui-2">T-Mobile updating Galaxy Note 10</a></span> </div> </div> <div class="views-row views-row-2 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/23/t-mobile-internal-report-comcast-possible-merger">T-Mobile internal report names</a></span> </div> </div> <div class="views-row views-row-3 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/04/fcc-accuses-verizon-t-mobile-us-cellular-misrepresenting-coverage-maps">FCC accuses Verizon, T-Mobile, and</a></span> </div> </div> <div class="views-row views-row-4 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/04/t-mobile-free-starbucks-gift-card-tuesday">T-Mobile customers can get a free</a></span> </div> </div> <div class="views-row views-row-5 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/02/t-mobile-5g-launch">T-Mobile&#039;s nationwide 5G</a></span> </div> </div> <div class="views-row views-row-6 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/26/will-5g-be-must-have-feature-your-next-iphone">Will 5G be a must-have feature for</a></span> </div> </div> <div class="views-row views-row-7 views-row-odd views-row-last"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/11/25/texas-nevada-leave-lawsuit-t-mobile-sprint-merger">Texas and Nevada drop out of</a></span> </div> </div> </div> </div> </div>
</div><div id="block-views-carrier-news-block-3" class="block block-views" > <h2 >Verizon Wireless</h2> <div class="content"> <div class="view view-carrier-news view-id-carrier_news view-display-id-block_3 veriszon-news-block view-dom-id-eb47bc060951c38a10d3ed62248ddd8d"> <div class="view-content"> <div class="views-row views-row-1 views-row-odd views-row-first"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2020/01/10/oneplus-8-verizon-5g-rumor">OnePlus 8 will reportedly launch</a></span> </div> </div> <div class="views-row views-row-2 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2020/01/07/verizon-launch-20-5g-devices-2020">Verizon will launch 20 5G devices</a></span> </div> </div> <div class="views-row views-row-3 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/23/verizon-5g-cleveland-columbus-hampton-roads">Verizon 5G expands again, now</a></span> </div> </div> <div class="views-row views-row-4 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/20/galaxy-note-10-android-10-update-us">Samsung Galaxy Note 10 starts</a></span> </div> </div> <div class="views-row views-row-5 views-row-odd"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/20/verizon-5g-charlotte-miami-greensboro-salt-lake-city-spokane-grand-rapids">Verizon 5G goes live in 6 more</a></span> </div> </div> <div class="views-row views-row-6 views-row-even"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/19/verizon-5g-memphis">Verizon 5G reaches its 22nd city</a></span> </div> </div> <div class="views-row views-row-7 views-row-odd views-row-last"> <div class="views-field views-field-title"> <span class="field-content"><a href="/2019/12/18/verizon-5g-hoboken">Verizon turns on its 21st 5G city</a></span> </div> </div> </div> </div> </div>
</div><div id="block-phonedog-phonedog-pd-mobile-320-50" class="block block-phonedog" > <div class="content"> <!-- /41014381/PhoneDog/PD_Mobile_320x50 --><div class="dfp-mobile-footer" id="dfp-gpt-ad-320x50-a" style="height:50px; width:320px;"> <script type="text/javascript"> if(document.getElementById("dfp-gpt-ad-320x50-a").offsetLeft > 0) { googletag.cmd.push(function () { googletag.display("dfp-gpt-ad-320x50-a");});} </script> </div> </div>
</div> </div> </div> </div> </div>
</div>
<footer> <div class="row"> <div class="large-7 columns footer-left"> <h2>PHONEDOG</h2> <p>PhoneDog Media is home to PhoneDog, Android & Me, TmoNews, and TodaysiPhone. The network receives 2.5 million unique visitors and 10 million pageviews each month, along with a combined three million video views on YouTube.</p> <p>While the name is jovial, the PhoneDog Media network offers up a wealth of written and video content to help readers make important decisions about mobile technology.</p> <p>Established in 2001, PhoneDog Media is a privately owned and operated company.</p> <h2 class="media-family">PHONEDOG MEDIA FAMILY</h2> <ul class="large-block-grid-2"> <li><a href="/" >Phonedog - Cell Phone News</a></li> <li><a href="http://www.tmonews.com/" >TmoNews - The Unofficial T-Mobile Blog</a></li> </ul> </div> <div class="large-5 columns footer-right"> <div class="footer-content"> <div class="footer-menus"> <ul> <li><h2>Company</h2></li> <li><a href="/">Home</a></li> <li><a href="/about-phonedog">Privacy Policy<br/> Term of Use<br/> Contact<br/> About Us</a></li> <li><a href="/sitemap">Sitemap</a></li> </ul> <ul id="footer-popular"><li class="menu-5023 first"><a href="/reviews" title="Phone and app reviews">In-Depth Reviews</a></li>
<li class="menu-5024"><a href="/tags/head-to-head-reviews" title="Dogfight">Phone vs Phone</a></li>
<li class="menu-5038"><a href="/tags/unboxing" title="Watch phone unboxings">Video Unboxings</a></li>
<li class="menu-5039"><a href="/cell-phone-app-reviews" title="Cell phone application reviews">Apps &amp; Games</a></li>
<li class="menu-5068 last"><a href="/tags/new-phones" title="New phone coming to market">New Phones</a></li>
</ul> <ul id="footer-research" class="last clearfix"><li class="menu-5070 first"><a href="/products/find" title="Find a phone">Phone Finder</a></li>
<li class="menu-5071"><a href="/cell-phone-research/compare-plans" title="Find a cell phone plan">Compare Plans</a></li>
<li class="menu-5072"><a href="/cell-phone-shopping/specials" title="Current carrier specials">Phone Specials</a></li>
<li class="menu-5073 last"><a href="/long-distance" title="Long distance calling plans">Long Distance</a></li>
</ul> </div> <div class="footer-social"> <img src="/sites/phonedog.com/themes/phonedog/images/footer-dog.jpg" class="dog-footer" /> <a href="https://www.facebook.com/phonedog" target="_blank"> <img src="/sites/phonedog.com/themes/phonedog/images/footer-fb-icon.png" class="social-icon" /> </a> <a href="https://www.twitter.com/phonedog" target="_blank"> <img src="/sites/phonedog.com/themes/phonedog/images/footer-tw-icon.png" class="social-icon" /> </a> <a href="https://www.youtube.com/user/phonedog" target="_blank"> <img src="/sites/phonedog.com/themes/phonedog/images/footer-yt-icon.png" class="social-icon" /> </a> <a href="https://feeds.phonedog.com/phonedog_cellphoneblog" target="_blank"> <img src="/sites/phonedog.com/themes/phonedog/images/footer-feed-icon.png" class="social-icon" /> </a> </div> </div> </div> <div class="large-12 columns footer-copyright"> <p class="copyright">&copy; 2001-2020 Slashdot Media.</p> <p>Reproduction without explicit permission is prohibited. All Rights Reserved. </p> <img src="/sites/phonedog.com/themes/phonedog/images/footer-affiliate.png" class="footer-affiliate" /> </div> <div class="yieldmo ym-footer clearfix"> <div id="ym_672858879004712825" class="ym"></div><script type="text/javascript">(function(e,t){if(t._ym===void 0){t._ym="";var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.min.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)}else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);</script> </div> </div>
</footer><!--END FOOTER-->
        
    

    <!-- phonedog_display_mobile_anchor_b -->
    <div id="scripts">
      <script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_6ft2LzKmbYzQLB8d1StADOFctXy15N2CmZnE9CfeNMM.js"></script>
<script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_3vSVbRJMflESrC9rdahVpSs9I7VqCerMc8YN7FSVZMg.js"></script>
<script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js__c4xL_g8GMaQalXIOwK3j1p3ZQb-fZ8MgWDjX8r_DcE.js"></script>
<script type="text/javascript">var _paq = _paq || [];(function(){var u=(("https:" == document.location.protocol) ? "https://analytics.phonedog.com/" : "http://analytics.phonedog.com/");_paq.push(["setSiteId", "34"]);_paq.push(["setTrackerUrl", u+"piwik.php"]);_paq.push(["setDocumentTitle", "Are%20you%20interested%20in%20Samsung%27s%20XCover%20Pro%3F"]);_paq.push(["setDoNotTrack", 1]);_paq.push(["trackPageView"]);_paq.push(["setIgnoreClasses", ["no-tracking","colorbox"]]);_paq.push(["enableLinkTracking"]);var d=document,g=d.createElement("script"),s=d.getElementsByTagName("script")[0];g.type="text/javascript";g.defer=true;g.async=true;g.src=u+"playnice.js";s.parentNode.insertBefore(g,s);})();</script>
<script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_G8xlEZVgRU4Vkj9KCeDZCplCrMGMu-kBk-R4ckXL3mw.js"></script>
<script type="text/javascript" defer="defer">var residential ="/compare-home-phone-service"</script>
<script type="text/javascript" defer="defer">jQuery(document).ready(function () {
        showsidetable(640,"top");
      });</script>
<script type="text/javascript" defer="defer">jQuery(document).ready(function () {
		 showsidetable(644,"side");
      });</script>
<script type="text/javascript" defer="defer">jQuery(document).ready(function () {
        showsidetable(676,"res");
      });</script>
<script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_tohoW3twjd_OSPfKXmVI7MehgV6-owA0T9aRVyG2VmA.js"></script>
<script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_ba84ID84fQiFLji9b0FN4c9Hcl8BRZnW_q9W43vWub0.js"></script>
<script type="text/javascript" src="https://www.phonedog.com/sites/phonedog.com/files/js/js_GYPsJefnX-ALT58RZTAnVqoKeuIEzDq2Ov7PapR_u5g.js"></script>
<script type="text/javascript" defer="defer">(function($) {
    Drupal.behaviors.phonedog_whatsapp = {
      attach: function(context, settings) {
        if(typeof wabtn4fg==="undefined"){
          wabtn4fg=1;h=document.head||document.getElementsByTagName("head")[0],s=document.createElement("script");
          s.type="text/javascript";
          s.src="/sites/phonedog.com/themes/phonedog/js/whatsapp-button.js";
          h.appendChild(s);
        }
      }
    }
  })(jQuery);</script>
<script type="text/javascript">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</script>
	  <!-- instinctive ad -->
	  <script defer>
	    (function () {
		  var tag = document.createElement('script');
		  tag.src = 'https://load.instinctiveads.com/i.js';
		  var node = document.getElementsByTagName("script")[0];
		  node.parentNode.insertBefore(tag, node);
	    })();
	  </script>
	  <!-- end instinctive ad -->
	        <script type="text/javascript">(function(e,t){if(t._ym===void 0){t._ym="";var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.min.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)}else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);</script>
      <!-- Skimlink Tag -->
      <script>
      jQuery.getScript('//s.skimresources.com/js/76923X1529986.skimlinks.js', function(){});
      </script>
      <!-- End Skimlink Tag -->
      <!-- deferred loading of external javascript via jQuery
           set up necessary containers first  -->
      <div id="fb-root"></div>
      <!-- now load tag scripts -->
      <script type="text/javascript">
        jQuery().ready(function() {
          // Facebook SDK stuff
          (function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.0";
            fjs.parentNode.insertBefore(js, fjs);
          }(document, 'script', 'facebook-jssdk'));

        });
      </script>

      <script src="//ads.pro-market.net/ads/scripts/site-139274.js" async></script>
      <!-- CrossPixel Tag -->
      <script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=44&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>
      <!-- End CrossPixel -->
      <!-- Taboola -->
      <script type="text/javascript">
        window._taboola = window._taboola || [];
        _taboola.push({flush: true});
      </script>
      <script defer="defer"  src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=a0b5e2c3-e23a-46ad-aaa9-b97d3fb22e00"></script>
   </body>
 </html>
          </div>
      </body>
</html>
